Google Update Impacting Google Workspace Performance for Reveal Users

Incident Report for GetReprise

Resolved

Version 1.1.12 of the Reveal extension has been published in the Chrome Store.
Posted Jun 10, 2024 - 21:35 UTC

Identified

Reprise identified a Google update that was pushed this morning, which has impacted the Google Workspace performance for Reprise Users who downloaded version 1.1.11 or prior of the Reveal extension.

This does not impact any functionality in Reprise, only the Google Workspace experience for Users with the extension installed.

We have a fix (1.1.12) and are pushing it to the Chrome Store now. The Status page will be updated once the latest version is published by the Chrome Store.
Posted Jun 10, 2024 - 21:15 UTC
This incident affected: Reveal.